Главная | Случайная
Обратная связь

ТОР 5 статей:

Методические подходы к анализу финансового состояния предприятия

Проблема периодизации русской литературы ХХ века. Краткая характеристика второй половины ХХ века

Ценовые и неценовые факторы

Характеристика шлифовальных кругов и ее маркировка

Служебные части речи. Предлог. Союз. Частицы

КАТЕГОРИИ:






Глава 1. Алгоритмы линейной и разветвляющейся структуры




Пример 1.1. Простейший алгоритм, запрашивающий имя и затем приветствующий

Его обладателя.

Тест

Данные Результат
Имя = “Тимур” “Привет, Тимур”

Алгоритмический язык

алг Знакомство (арг лит Имя, рез лит t)

нач

вывод "Как тебя зовут ?"

ввод Имя

t := "Привет, " + Имя + "!" | "+" - операция сцепки

вывод t

кон

Turbo Pascal

Program Hello;

Var Name: String; {Описание переменной Name строкового типа}

BEGIN

Write('Как тебя зовут ? '); {Вывод на экран текста вопроса}

ReadLn(Name); {Ввод c клавиатуры имени}

WriteLn('Привет, ', Name, '!'); {Вывод на экран приветствия}

ReadLn;

END.

Здесь последний оператор ReadLn позволяет видеть на экране результаты работы программы, пока не будет нажата клавиша <Enter>.

Результаты работы Pascal-программы

Как тебя зовут ? Тимур <Enter> Привет, Тимур !

Пример 1.2. Определить объём и площадь боковой поверхности цилиндра с заданными радиусом основания R и высотой H.

Тест

Данные Результат
R = 1 H = 1 V = 3.14 S = 6.28
       

Алгоритмический язык

алг Цилиндр (арг вещ R, H, рез вещ V, S)

нач вещ Pi

Pi := 3.14

V := Pi * R**2 * H

S := 2 * Pi * R * H

кон

Turbo Pascal

Program Cylinder;

Uses Crt; {Подключение библиотеки Crt}

Const

Pi=3.14;

Var

R, {радиус основания цилиндра}

H, {высота цилиндра }

V, {объем цилиндра }

S: Real; {площадь боковой поверхности цилиндра}

BEGIN

ClrScr; {Вызов из библиотеки Crt процедуры очистки экрана}

Write('Введите высоту цилиндра : '); ReadLn(H);

Write('Введите радиус основания : '); ReadLn(R);

V := Pi * R * R * H;

S := 2 * Pi * R * H; WriteLn;

WriteLn('Объем цилиндра = ', V : 5 : 2); {Здесь 5 – общее количество позиций, занимаемых переменной V при выводе, а 2 - количество позиций в дробной части значения V}

WriteLn('Площадь боковой поверхности = ', S : 5 : 2);

ReadLn;

END.







Не нашли, что искали? Воспользуйтесь поиском:

vikidalka.ru - 2015-2021 год. Все права принадлежат их авторам! Нарушение авторских прав | Нарушение персональных данных